Thursday, January 31, 2008

Cisco Router as DHCP Server

All Cisco Layer3 switches & routers, have the capability to run a DHCP server. Sooner or latter you will find yourself with the need to configure a router as a DHCP Server.

The configuration is quiet straight forward. Lets say we have the following interface to our LAN:
!
interface FastEthernet 0/0
 description Uplink to Users Segment
 ip address 10.10.10.1 255.255.255.0
 ...
!


Lets configure a DHCP server with the following parameters:
  1. Exclude the first 10 IPs from the DHCP range 
  2. Use 172.16.10.10 and 172.16.10.11 as the DNS servers 
  3. Use monids.org as the domain 
  4. Max lease will be set to 4 hours 
  5. Secure ARP table entries to DHCP leases in the DHCP database 
  6. Disable dynamic ARP learning on an interface (DHCP leases will be installing the authorized entries)
Well, the first four (4) parameters are the most common parameters, but lets do them all together:


!
ip dhcp excluded-address 10.10.10.1 10.10.10.10
!
ip dhcp pool MyPOOL
 network 10.10.10.0 255.255.255.0
 default-router 10.10.10.1
 dns-server 172.16.10.10 172.16.10.11
 domain-name monids.org
 lease 0 4
 update arp ! This will keep tracking of the mac-address of the client
!
!
interface FastEthernet 0/0
 description Uplink to Users Segment
 ip address 10.10.10.1 255.255.255.0
 ...
 arp authorized !IP to MAC mapping can only be installed by the authorized subsystem
 arp timeout 60 !How long an entry remains in the ARP cache
 arp probe interval 5 count 15 !Interval, in seconds, and number of probe retries!
!

And this will be the whole configuration. For clarification of the syntax of two parameters:
  • "lease {days [hours] [minutes]| infinite}" will
  • "arp probe interval {seconds} count {number}" will remove the arp cache entry if the peer does not answer after "{number}" amount of probes. Each probe will be send "{seconds}" seconds apart.
The "update arp" and "arp authorized" are some of the DHCP security features available at the Cisco IOS.

For more information on DHCP configuration on IOS and features available visit this link.

7 comments:

  1. I was searching this up for my brother's assignment. I don't get much of it, but I understand the idea. Hopefully this will help him through. Thank you so much for sharing this informationl

    ReplyDelete
  2. Thanks for sharing such huge content keep posting further
    upcoming events in karachi

    ReplyDelete
  3. Welcome to We Buy Houses Los Angeles, the Official Cash Home Buyer of Los Angeles, California, and surrounding areas.

    We provide home sellers with a cash option to purchase their property quickly—with NO Repairs, and NO Fees or Commissions.

    Simply go to our website or call us at (213) 290-4980 to get a no-obligation cash home offer sent to you. It’s free and confidential.

    Avoiding foreclosure? Facing divorce? Moving? Upside down in your mortgage? Liens? It doesn’t matter whether you live in it, you’re renting it out, it’s vacant, or not even habitable. We help owners who have inherited an unwanted property, own a vacant house, are behind on payments, owe liens, downsized, and can’t sell… even if the house needs repairs that you can’t pay for… and yes, even if the house is fire damaged or has bad rental tenants.

    Basically, if you have a property and need to sell it… we’d like to make you a fair cash offer and close on it when you’re ready to sell.

    Just contact us today to get started!

    ReplyDelete
  4. Keep sharing stuff like this I am fascinated by this and want to learn more.
    Custom Logo Design

    ReplyDelete
  5. I am very happy after visiting your website with very useful information. I am from one of the digital marketing agency... To visit my agency click on link Visitdigitalguru

    ReplyDelete
  6. Thanks for sharing informative content…Find noida software company to know more and Contact us on given no.…

    ReplyDelete
  7. This content material is written very well. Your use of formatting when making your factors makes your observations very clear and clean to apprehend. Thank you.


    law dissertation Writing Service

    ReplyDelete